CREATING AND USING TEAM PROJECTS

OVERVIEW

Team projects enable multiple Axure RP users to co-author one file. Team projects also maintain a history of project revisions which can be retrieved at any time. Users edit local copies of the team project and use a "check in, check out" system to manage updates.

HOW TEAM PROJECTS WORK

Each team project comprises a central copy of the project—called the "team directory"—that manages the shared resources, and one or many local copies, each belonging to a co-author contributing to the team project. A team project's team directory may be located on Axure Share, an SVN server, or a network drive.


Each user can check out pages and other project attributes (masters, generators) for editing in their local copy. When a page is checked out to one user, no other user can edit that page. When changes are complete, the user can check in their changes to the team project. The checked-in changes can be viewed by other users, and the checked-in pages and attributes are freed up to be checked out by another co-author for further editing.

THE TEAM DIRECTORY LOCATION

Team projects can use Axure's custom check in / check out protocol when the team directory is on Axure Share or Axure Share Enterprise. When the team directory is located on a network drive or SVN server, the team project instead uses the open-source Subversion (SVN) protocol to manage check-ins and check-outs.


Learn how to set up an Axure Share or SVN team project below.

AXURE SHARE

Once you've opened the Create Team Project dialog following one of the methods described above, make sure you're on the "Axure Share" tab.


If you aren't yet logged in to an Axure account in RP, create one or log in to your account via the dialog interface. In the "Folder" field, choose the Axure Share workspace that will contain the team project. You'll need to invite all your co-authors to join the workspace. (If you don't already have a workspace for your project configured, log in to share.axure.com in a web browser to set one up. Learn how to make a workspace and invite colleagues to it in this training article.)


Name the project in the "Team Project Name" field.


In the "Local Directory" field, choose the location where your local copy will be saved.


Team projects on Axure Share automatically regenerate the HTML output each time changes are sent or checked in. The bottom, optional "URL Password" field can be used to password-protect the team project's HTML output.

SUBVERSION (SVN)

When you've opened the "Create Team Project" following one of the methods described above, switch to the "SVN" tab.


In the Team Directory field, enter or navigate to the SVN server or network drive containing the team directory. (If you are working alone but would like to use the team projects feature to keep a history of revisions, you could choose a local drive.)


Name the project in the "Team Project Name" field.


In the "Local Directory" field, choose the location where your local copy will be saved.

Use this process to get a local copy of a team project that has already been created.


Note that once you have one local copy of a particular team project on your computer, you can keep working in the same local copy by double-clicking its .rpprj file in your file system, just as you would open a regular file in RP by launching its .rp file. (To see the latest updates in the project, go to "Team > Get All Changes from Team Directory".) It isn't necessary to get a new local copy of a team project each time you want to access it.

MORE RESOURCES

If you're having trouble creating or working with an SVN team project, please visit our SVN Team Projects Troubleshooting Guide.

© 2002-2016 Axure Software Solutions, Inc. All rights reserved. Axure ® is a registered trademark of Axure Software Solutions, Inc.

86% OF THE FORTUNE 100

USE AXURE RP

AXURE

RESOURCES

LEGAL

CONNECT

EMAIL

CREATING A NEW TEAM PROJECT

You can make a team project from an existing .rp file, or you can start a new, blank team project. To convert an .rp file, open the file and then go to "Team > Create Team Project from Current File". To start from a new, blank team project, go to "File > New Team Project...". Either way, you'll end up in the Create Team Project dialog.

AXURE SHARE

To get a local copy of a team project hosted on Axure Share, you'll need an account that's been invited to the workspace containing the team directory. Learn about workspaces on Axure Share here.


To start, navigate to "Team > Get and Open Team Project...". Make sure you're on the "Axure Share" tab. If you aren't yet logged in to an Axure account in RP, create one or log in to your account via the dialog interface.


In the "AxShare ID" field, you can enter the 6-digit project ID if you know it. Otherwise, click the "..." button to navigate to the workspace and project you want.


In the "Local Directory" field, choose the location where your local copy will be saved.


Click "Get" to get and open a local copy of the project.

SUBVERSION (SVN)

To start, navigate to "Team > Get and Open Team Project." Switch to the "SVN" tab.


In the "Team Directory" field, navigate to the the team directory (or type it in if you know it).

 

(If you're having trouble finding the team directory, note that the name of the team directory should include the project name as the last subfolder. You can get a team member to help find the team directory by asking them to go to "Team > Browse Team Project History" in an existing local copy. The team directory is shown in that dialog.)

 

In the "Local Directory" field, choose the location where your local copy will be saved.


Click "Get" to get and open a local copy of the project.

THE LOCAL COPY IN YOUR FILE SYSTEM

The local copy of the team project consists of an .rpprj file and a folder named "DO_NOT_EDIT". This folder contains project data and version control information that should not be modified outside of Axure RP. If you move the .rpprj file, make sure to move the DO_NOT_EDIT folder along with it.

 

When you want to work on the project, open the .rpprj file. You don't need to get a new local copy each time.

WORKING WITH A TEAM PROJECT

Changes that you make in your local copy must be either "sent" or "checked in" to the team project before your co-authors can see them. Below, learn how to "check out" items for editing and then send or check in your changes after you've made them. Also learn how to get changes from the team directory so that you can see your teammates' changes.

CHECKING OUT ITEMS FOR EDITING

To edit a page, master, or generator, you must check it out. When you check out an item, you'll also automatically get the latest changes to it (if you don't have the latest version already) and it will be reserved for you exclusively. You can then edit on the canvas like you would a page or master in a regular .rp file.


To check out a page or master, right-click it in the Pages or Masters pane and choose "Check Out" from the context menu. Another way to check out a page or master is to first open it on the canvas and then click the "Check Out" button appearing at the top-right corner of the canvas when you hover over the diagram.


To check out a generator, open the generator and click "Check Out" in the top-right corner of the dialog.

 

You can also use the "Team > Check Out Everything" menu command to check out all of the pages, masters, and generators in the team project.


Keep in mind that check-outs are per local copy and not per user. That is: if you have a local copy on your desktop computer and another one on your laptop, a check-out from your laptop will not result in that same item being checked out to you on your desktop computer. Instead, your desktop computer copy will reflect that someone with your user account name has that item checked out, which will be the case—because the "you" on your laptop has it checked out.

CHANGES THAT DON'T REQUIRE A CHECK-OUT

Some project properties can be edited without a check-out. These include styles, global variables, widget note and page notes fields, and adaptive views. You can also add, delete, and reorganize pages and masters without a check out. This allows multiple people to work with these project properties at the same time. Any changes to items in this category will be sent whenever you do a check-in on the project to a page, master, generator, or or when you perform a "Send All Changes" or "Check In Everything".

CHECKING IN

When you check in, you send to the team directory all of the changes you've made to your local copy. For items you've checked out (i.e. pages, masters, and generators), a check-in will also release the item so that others are able to check it out for further editing.


To check in a page or master, right-click it in the Pages or Masters pane and choose "Check In". Any changes you've made to items that don't require a check-out (as noted above) will be sent at this time, too.


To check in a generator, open the generator and click "Check In" in the top-right corner of the dialog.


You can also go to "Team > Check In [current page name]" or "Team > Check In Everything".


The "Check In" dialog will open. At the top of the dialog you'll see a list of all the project items (pages, etc) being checked in. At the bottom, write your check-in notes.


Each time you check in, a new revision of the team project is stored in the team project directory. You can access those revisions in the Team Project History Browser (explained later in this article).


It's a good idea to check in your changes regularly so that your team members can see them, and also so that you have a saved record of your work.

GETTING CHANGES

Following on the above, it's also good idea to regularly get your co-authors' changes. Go to "Team > Get All Changes from Team Directory" to update your entire local copy with the latest from the team directory.


You can also right-click a page or master and click "Get Changes" to update that particular page or master, along with any project attributes used by that page or master. For generators, open the dropdown in the top-right corner of the generator dialog and click "Get Changes".

SENDING CHANGES

You can "send changes" when you want to update the team directory with your recent changes but want to keep pages, masters, or generators checked out to you for further editing.


Go to "Team > Send All Changes to Team Directory" to send everything.


You can also right-click a page or master and click "Send Changes" to send your changes to that particular page or master plus related project attributes. For generators, open the dropdown in the top-right corner of the generator dialog and click "Send Changes".


The "Send Changes" dialog will open. At the top of the dialog you'll see a list of all the project items (pages, etc) with changes to send. At the bottom, write your change notes.


Each time you send changes, a new revision of the team project is stored in the team directory. You can access those revisions in the Team Project History Browser (explained later in this article).

UNDOING A CHECK-OUT

You can cancel all your changes that have not been checked in and revert to the latest check-in by using "Undo Check Out". This menu option will also revert the item to being available for check-out.


To cancel all changes you've made to a page or master since you checked it out, right-click its name in the Pages or Masters pane and click "Undo Check Out".


To cancel changes made to a generator, open the dropdown in the top-right corner of the generator dialog and click "Undo Check Out".


To cancel all changes in your local copy, go to "Team > Undo All Check Outs".

UNSAFE CHECK-OUTS

If you try to check out an item that's already checked out to another local copy—either to a co-author or to another of your own copies—you'll see the "Unable to Check Out" dialog. The default option in this dialog is "Do Not Edit", which leaves the requested item alone. You'll be able to see the username of the author to which the item is checked out. You can choose "Do Not Edit" and then contact the team member to ask them to check in the item so you can work with it.


You can alternatively choose the option "Edit w/o Check Out". If you choose this option, you'll have an "unsafe check-out" of the item. You'll be able to edit the page, even though it's checked out to your team member.


MANAGING AND VIEWING TEAM PROJECT HISTORY

THE "MANAGE TEAM PROJECT" DIALOG

You can view a list of all pages, masters, and generators, along with information about each one, including: whether it is checked out and to whom; whether there are changes in the team directory that aren't in your local copy; and whether you have made changes in your local copy that haven't been checked in.

 

Go to "Team > Manage Team Project". Click "Refresh" to get an updated list of items and their status.


You can right-click any listed item in the dialog and choose to get changes, send changes, check in, check out, or undo a check-out.

THE TEAM PROJECT HISTORY BROWSER

Every time items are checked in or changes are sent to the team directory, a "revision" is created—a saved version of the entire team project at that moment. These revisions are browsable and exportable via the Team Project History Browser.


Go to "Team > Browse Team Project History". Use the "Start Date" and "End Date" fields to specify the time range in which you want to see the revisions. Click "Get History" to get a list of all revisions from within that range.


You'll see a list of revisions in the center of the "Team Project History Browser" dialog. Click a revision to see the change notes and a list of all the project items that were changed in that revision—you'll find them in the "Check In Notes" section at the bottom of the dialog.

 

You can export the currently selected revision to an .rp file by clicking "Export to RP File" at the bottom-left of the dialog.

EXPORTING A TEAM PROJECT TO AN RP FILE

You can export a team project to a regular .rp file. This can be useful if you want to move the team directory or otherwise preserve the current state of a team project.


To export your local copy to a .rp file, go to "File > Export Team Project to File...".


You can also retrieve any revision as a standalone .rp file using the method described in the previous section.

MOVING THE TEAM DIRECTORY (SVN ONLY)

Before moving a team directory, have all team members check in everything from their local copies. When moving the team directory, be sure to move the project folder and all its contents.


After moving a team directory, the existing local copies will remain pointed to the previous, now incorrect, team directory. To repoint an existing local copy to a new location, choose "Team > Repoint to Moved Team Directory…" and paste in, type in, or navigate to the new team directory. Alternatively, you can get a new local copy from the new team directory.

MOVING AN SVN TEAM PROJECT TO AXURE SHARE

When moving an SVN team project to Axure Share, follow these steps.

1. CHECK IN EVERYTHING

Ask everyone working in the SVN team project to check in all of their changes.

2. GET ALL CHANGES

Sync your local copy of the SVN team project with the team directory using the "Team > Get All Changes from Team Directory" menu command.

3. EXPORT AN RP FILE

Still in the SVN team project local copy, export a standalone .rp file using the "File > Export File from Team Project" menu command.

4. CREATE THE NEW PROJECT

Open the exported standalone .rp file and use the "Team > Create Team Project from Current File" menu command to recreate your team project. Follow the steps outlined above to create the team project on Axure Share.

5. NEW LOCAL COPIES

Each person working on the project will need to get a new local copy from Axure Share, following the steps given above.

UPGRADING A TEAM PROJECT TO RP 8 FROM

AN EARLIER VERSION OF AXURE RP

A team project created in any earlier major release of Axure RP (7.0, 6.5, etc.) will need to be exported to a regular .rp file and then recreated as a team project in RP 8.


(If you're upgrading across multiple major releases, it's always recommended to open and resave your .rp file in each successive major release.)

1. CHECK IN EVERYTHING

Ask everyone working in the project to use the earlier version of RP to check in all of their changes.

2. GET ALL CHANGES

Using the earlier version of RP, sync your local copy with the team directory using the "Team > Get All Changes from Team Directory" menu command.

3. EXPORT AN RP FILE

Still in the earlier version of RP, export a standalone .rp file using the "File > Export File from Team Project" menu command.


If you’ve already uninstalled the earlier version of RP, you should still be able to export a recent version of your project from RP 8. To do this, go to the "Team > Browse Team Project History" menu command. In the resulting dialog, select the most recent available version of your project and choose to "Export to RP File".

4. CREATE THE NEW PROJECT

Open the exported standalone .rp file in RP 8 and use the "Team > Create Team Project from Current File" menu command to recreate your team project.

5. NEW LOCAL COPIES

Each person working on the project will need to get a new local copy in RP 8.


Note that these steps are only necessary when moving between major releases (e.g. Axure RP 7 to Axure RP 8). For smaller updates, you won't need to go through this process.

SETTING UP AN SVN SERVER

The team directory is frequently stored on a file server. If your network connection is slow or if you connect through a VPN, check-ins and check-outs can sometimes be very slow. Setting up an SVN server instead of a regular file server to store the team directory can dramatically improve the performance of these operations in some scenarios.


If you're unfamiliar with SVN, you can get started by checking out Red Bean's free online resource Version Control with Subversion. For the easiest setup on a Windows Server machine, consider using VisualSVN's free product VisualSVN Server.


Another option is to use an SVN hosting service. We've successfully used Unfuddle and SVN Repository.


Once you have an SVN server, you'll need to create users and grant access to everyone who will be editing the team project. Most hosted SVN services provide an interface to add users.


Finally, enter the link to the SVN server as the location for the team directory when creating a team project (following the steps explained above).

You typically won't want to do an unsafe check-out as it can lead to a conflict. A conflict occurs when multiple local copies edit the same item at the same time, and the team directory can only choose one set of changes to accept. The other set(s) of changes are dismissed, and will need to be manually reapplied.


But an unsafe check-out can be useful if there's an issue preventing a page from being checked in from the local copy where it's currently checked out—like if there's a hardware issue with the computer that has the local copy, if there's a temporary problem connecting to the team directory to do a check-out, or if a colleague forgot to check in before leaving for vacation.

GETTING AN EXISTING TEAM PROJECT